Grammalecte  View Ticket

UUID: dc9802dc2dc97cb14009d3489bdb64a58ca3238a
Title/Titre: 0.6.1: missing built elements
Status: Closed Type: Build_Problem
Severity/Gravité: Critical Priority/Priorité: Immediate
Module: Grammalecte_Core Resolution: Fixed
Modified/Modifié: 2018-10-06 16:03:40
Version(s): 0.6.1
Comments / Commentaires :
anonymous // 2017-12-04 12:20:09 : (text/x-fossil-plain)
Something seems to have change between 0.6.0 and 0.6.1

+ /usr/bin/python3 ./make.py fr -b -d -js
Python: 3.5.4 (default, Oct  9 2017, 12:07:29) 
[GCC 6.4.1 20170727 (Red Hat 6.4.1-1)]
# Error. Couldn’t import file build_data.py in folder gc_lang/fr
...

BTW, this error exists in previous version and was not a blocker


+ /usr/bin/python3 ./make.py fr -t
Python: 3.5.4 (default, Oct  9 2017, 12:07:29) 
[GCC 6.4.1 20170727 (Red Hat 6.4.1-1)]
============== MAKE GRAMMALECTE [fr] at 13 h 15 min 43 s ==============
...
> Running tests
# Error. Couldn't import file fr_test.py in folder tests
+ exit 0

Diffing the generated content
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/__pycache__/cli.cpython-35.opt-1.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/__pycache__/cli.cpython-35.pyc
added       /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/__pycache__/grammalecte-cli.cpython-35.opt-1.pyc
added       /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/__pycache__/grammalecte-cli.cpython-35.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/cli.py
added       /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte-cli.py
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/__pycache__/conj_data.cpython-35.opt-1.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/__pycache__/conj_data.cpython-35.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/__pycache__/mfsp_data.cpython-35.opt-1.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/__pycache__/mfsp_data.cpython-35.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/__pycache__/phonet_data.cpython-35.opt-1.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/__pycache__/phonet_data.cpython-35.pyc
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/conj_data.py
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/mfsp_data.py
removed     /usr/lib64/libreoffice/share/extensions/grammalecte/pythonpath/grammalecte/fr/phonet_data.py



And... it doesn't work anymore.

olr // 2017-12-18 14:38:39 : (text/x-fossil-plain)
Sorry for the late answer.

This problem won’t be easy to solve, except if I go back to the previous situation, which was far from being ideal.

This is not a problem with tests. This is a building problem.

The issue is that Grammalecte needs itself to build itself. That’s why you already had an error previously, but it was non blocking because built elements were already provided within the sources.

I don’t think I have much choice to solve the situation. As a temporary solution, I will include anew these pre-built elements.

olr // 2017-12-18 15:08:36 : (text/x-fossil-plain)
This problem should be solved now.